Joomla kļūda: Database Error: Unable to connect to the database:Could not connect to MySQL
Joomla izmanto datubāzi. Ja kāda iemesla dēļ neizdodas izveidot savienojumu ar datubāzi, var parādīties šāds ziņojums:
Database Error: Unable to connect to the database:Could not connect to MySQL
Failā configuration.php (tas atrodas mapē, kurā instalēta Joomla) atradīsiet šos iestatījumus savienojumam ar datubāzi:
var $host = 'localhost'; // Tas vienmēr ir localhost
var $user = 'XXX_ZZZ'; // XXX ir vadības paneļa lietotāja vārds, ZZZ ir datubāzes lietotājs
var $db = 'XXX_YYY'; // XXX ir vadības paneļa lietotāja vārds, YYY ir datubāzes nosaukums
var $password = 'parole'; // Parole, ko piešķīrāt datubāzes lietotājam
Ja nevarat izveidot savienojumu, iespējams, kaut kas nav kārtībā ar iepriekš minētajiem datiem.
Piesakieties vadības panelī un izvēlieties izvēlni MySQL. Pēc tam izvēlieties Joomla datubāzi (noklikšķiniet uz tās), un tiks parādīti esošie datubāzes lietotāji. Ja nepieciešams, izveidojiet jaunu datubāzes lietotāju un ievadiet tā lietotājvārdu un paroli failā configuration.php. Ja datubāzes lietotājs jau ir, drošības labad nomainiet paroli, lai tā sakristu ar configuration.php.
Ja Joomla instalējāt ar Installatron, datubāzes nosaukumu varat uzzināt arī Installatron.
